Honda CX 500 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey folks! I have new project bike - a 1979 CX500. The PO added LED flashers (and a digital/LED flasher relay). He said it used to work, but it's not working for me. All flashers, front, back, left and right do the same thing. I have attached a video link of what is happening. In addition to the turn signals not flashing more than once, the brake light BARELY gets brighter when I pump the brakes. I assume this is somehow related. Battery is fine and stays charged. Any thoughts? Thanks!

 

·
Registered
Joined
·
3,592 Posts
The relay seems busted . If it is, it can not be repaired, as far as I know . Change it with a new one, to see. If it is not the relay, then you at least got a spare you can keep . :)
 
  • Like
Reactions: tnewberry

·
Registered
Joined
·
2,679 Posts
On my bike it is behind the right side cover.
 

·
Registered
Joined
·
45 Posts
Hopefully it's not too late to mention that LED turn signals require a special relay. The standard thermal relay will not work.

With that gauge, you will also need a diode setup since the gauge indicator light is a single shared LED and no longer separate warning lights.

You can pick up the relay and the diode kit, together, for $13 from Products
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Yes, I ordered a digital "LED" relay for $6 on eBay. I confirmed it's compatibility.

The diode on the gauge works just fine, from what I can tell. I'll get the relay installed and check. Thanks.
 

·
Registered
Joined
·
2,679 Posts
Both foot and hand lever don't work?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
Correct. Every light works properly. Turn signals are now working (since I swapped out a new flasher relay). Head lights, high and low work. Brake light is on, but does not get brighter when I depress the either hand brake or foot brake. Any ideas?!
 

·
Registered
Joined
·
1,637 Posts
Correct 1157 two element brake light bulb ? Running light might work with brake element burned out. Bulb might be in backwards, it can be done. Switches hooked up and working, power in/out, front switch on brake master cylinder rear is pull wire from brake lever. Power to brake light? Run a jump wire from brake light base to negative terminal on battery to check ground.
 

·
Registered
Joined
·
2,679 Posts
Sounds like only the running lights is working and the brake light isn't. Perhaps check the connections to tail light.
 
1 - 13 of 13 Posts
Top