Honda CX 500 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 1978 cx500. Yesterday i was riding and noticed my turn signal indicator lights (on the dash) were dimmer than normal and eventually they faded and were out. Now when click the turn signal on, the relative light just goes out. The rear turn signals do not turn on at all. My brake light turns on only with the foot break, not the hand brake. The light fuses in the box both look fine. Just wondering if anyone has experience with this and could suggest a fixing process.

thanks so much!
 

·
Registered
Joined
·
2,282 Posts
It sounds like you have lost a ground in the system somewhere. Check all connections that go to ground and the connectors that contain the dark green terminals. There may be a lug inside the headlight bucket that needs a green terminal on too.
 

·
Registered
Joined
·
1,364 Posts
You need to get out your multimeter and a copy of the wiring diagram and start looking for bad grounds, high resistance switches, low battery voltage, charging issues, intermittent fuses etc.
 

·
Super Moderator
Joined
·
11,471 Posts
Agreed, start checking wiring connections. The best resource here is to go to the Quick Reference section in General Discussion. You will find the wiring diagrams, factory manuals, and much, much more.



As a starting point, take some electrical contact cleaner to your turn signal housing and work that in real good.
 

·
Registered
Joined
·
8,423 Posts

·
Registered
Joined
·
8,423 Posts
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top