Honda CX 500 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hi Everyone! I'm a memeber from the old site, finally found my way to the new. My mechanical seal on my 80CX started dripping from the weep hole....going in! I've read about the "Shep Method" of doing this, but cannot seem to locate it. Can any one help...send me a link?
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Found it. Thanks. I further read that running the bike 100 miles or so, it may correct itself. This bike has sat for at least 2 years. It was my parts bike. I then thought, it should be repaired instead of stripped. Running great...so far.
 

·
Registered
Joined
·
343 Posts
Mine weeps after it set up for any length of time, but usually stops after running for a while. Probably ought to get in on the next group buy

from Doward.( he's on the forum) One of these days the leak may not stop. AGB-1
 

·
Registered
Joined
·
16 Posts
If your bike is running good, oil is nice and oily with no water mixed in it, and you're not having to add water to the radiator every other day, I wouldn't worry at all about a few drips from the mechanical seal. One positive thing is that you know your weep hole is open. Many of us on this forum have had a lightly dripping mechanical seal "fix" itself just by putting mileage on the bike.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top