Honda CX 500 Forum banner
1 - 4 of 4 Posts

·
Registered
'82 GL500 '83 GL650 '21 RoyalEnfield INT650
Joined
·
2,472 Posts
My horn wasn't working and after some tapping with a plastic hammer, WD40, and adjusting the pitch screw it started working again.
I got three replacement horns from Sidecar Bob. Thanks Bob! They all work! The "least pretty" is the right pitch.
Reading above:
Can I change the tone with the little screw on the back to get harmonics? If so, I can choose a shineyer horn.
Thanks!
 

·
Registered
'82 GL500 '83 GL650 '21 RoyalEnfield INT650
Joined
·
2,472 Posts
Depending on the condition if the parts inside the horn you may be able to tweak the tone a bit but I've had them stop working instead in the past so it can be a bit of a gamble, although if that kills it it probably didn't have a lot of time left anyway.
Maybe I should play with my dead one first, then I have spares too. And I can probably shine up the one that is the right pitch. You are right, function is what matters. The 650's horns sound as good as the 500s now.
 

·
Registered
'82 GL500 '83 GL650 '21 RoyalEnfield INT650
Joined
·
2,472 Posts
I can't remember how they looked but if it is just grimy you should be able to wipe it off with a rag dipped in mineral spirits and if rusty you can gently sand it and give it a couple of light coats of black spray paint and it will probably look OK.
The Black is okay. I used aluminum foil on the chrome and steel wool . Maybe I'll try sandpaper. But it is fine for now. Happy to have a horn that you can hear!
 

·
Registered
'82 GL500 '83 GL650 '21 RoyalEnfield INT650
Joined
·
2,472 Posts
Okay, Zinc! The shiny outer ring. Thanks!

Lee
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top