Honda CX 500 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
Sorry if this topic is posted somewhere else already, but I tried for an hour and couldn't find it. I've got a 1982 gl500 that's pretty much stock with some new incandescent turn signals installed. The original two prong flasher relay went bad so I replaced it with a new one that also had two prongs. The new one would work for the most part, but every tenth or twelfth time I went to put on my turn signal it would flash solid and wouldn't blink, then would start working again a couple minutes later. I thought maybe I just got a bad relay, so I replaced it again with this one:

New Turn Signal Flasher Relay Honda GL500 XL500 CB650 CX650 GL650 CB750 CB900 | eBay

I thought maybe the extra green wire being connected would solve the problem. It came yesterday and I tried installing it this morning. I plugged in all three wires and flipped the left turn signal on. When I did it flashed erratically for maybe three seconds, then went dark. I tried the right side and it didn't flash at all. I tried the left side again and it also didn't flash. I pulled the new flasher off and tried the old one. Again, nothing. I tried starting up the engine to see if maybe the battery needed to charge up a little bit. Still nothing.

My headlight and tail light are both working and the turn signals that I have double as running lights and the running light part is still working. The bike starts up fine and everything else seems to be working great, but the turn signals won't flash. I guess my question is: what did I fry and can I fix it?
 

·
Registered
Joined
·
3,803 Posts
Start by checking the bulbs are not burnt out in the filaments.
If one or both front or back flasher bulb filaments are gone then they will not flash.
 

·
Registered
Joined
·
7,223 Posts
Check the fuses (one if for headlight, one for running lights I believe) as if you shorted the line with that green wire (its a ground that 2 prong flashers dont use, only the older 3 prong ones did) you will have popped the fuse.
 
1 - 5 of 5 Posts
Top