Honda CX 500 Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Iv'e been working on my '80 cx. Brought it back from the grave. I gave it a complete dissassemble and re-assemble. Carbs cleaned multiple times. It starts and runs beautiful....except at high speed...above 60mph. Seems to be running out of feul, but I'm convinced it is my 31 year old ignition starting to fail.Even in first or second gear, it will stammer above 5000 rpm. Now, what does the Ignitech do for me? Does it solve stator problems or CDI problems? I see there are aftermarket stators available which I will buy If I think it will fix it. The Ohm tests show slightly high resistance. Or I can wait and get in on the group buy on ignitech modules. Trying to decide where to spend my money. Any thoughts?
 

·
Registered
Joined
·
948 Posts
This is the way I understand it:



  1. The Ingitech will eliminate the need for the high speed windings on your stator. The power for your high speed will be derived from the battery.
  2. Your original stator can, as an option, be replaced by a GL model stator, for less money. The GL stator will also deliver more power, allowing you to run some accessories.
  3. The Ingitech will eliminate your CDI.
  4. The Ingitech will eliminate part of your advance timing system. I'm not real clear on this one yet, how it works, but it is another duty that the Ignitech will take over from your current system.



Others will chime in. Riders with these installed also claim improved motorcycle performance across the board.
 

·
Registered
Joined
·
17 Posts
Thats exactly what mine was doing, shutting down @ 5K rpm's. Bought the ignitech and all is well! Took about 20 mins to install and haven't looked back since. Suprising how much power these bikes have above 5K rpm's when their running right 8)

Good luck,

WillyB
 

·
Super Moderator
Joined
·
15,408 Posts
That really sums it up. Installing an ignitech removes a lot of bugs and using a g8 stator instead of a g47 give a lot more power.



I did both to my bike.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Sounds like the ignitech is the way to go. I have been following the "above 5000 rpm" thread also. Problem sounds very similer...So who do I talk to about getting in on the buy? I think I saw somewhere in here that wasen't going to happen until next spring. I hate to wait that long. With my ohm readings where they are, I might end up with both the module and a stator.
 

·
Registered
Joined
·
583 Posts
Sounds like the ignitech is the way to go. I have been following the "above 5000 rpm" thread also. Problem sounds very similer...So who do I talk to about getting in on the buy? I think I saw somewhere in here that wasen't going to happen until next spring. I hate to wait that long. With my ohm readings where they are, I might end up with both the module and a stator.
Go into the buy and sell forum, and pos or PM cobram. There is one going on now, with delivery expected mid August. I am also getting one!
 

·
Registered
Joined
·
8,423 Posts
Iv'e been working on my '80 cx. Brought it back from the grave. I gave it a complete dissassemble and re-assemble. Carbs cleaned multiple times. It starts and runs beautiful....except at high speed...above 60mph. Seems to be running out of feul, but I'm convinced it is my 31 year old ignition starting to fail.Even in first or second gear, it will stammer above 5000 rpm. Now, what does the Ignitech do for me? Does it solve stator problems or CDI problems? I see there are aftermarket stators available which I will buy If I think it will fix it. The Ohm tests show slightly high resistance. Or I can wait and get in on the group buy on ignitech modules. Trying to decide where to spend my money. Any thoughts?


Check that the vent hole in the fuel filler cap is clear.If blocked will cause fuel starvation.If inline fuel filter fitted make sure flow arrow direction is correct.



Also check plugs and plug caps.Click here,



http://globalcxglvtwins.hostingdelivered.com/viewtopic.php?f=10&t=335
 

·
Registered
Joined
·
2,282 Posts
It replaces the CDI box with another that draws it's power from the battery. So, if you stator's high or low speed windings have gone south, the igntech will solve that problem. And since it replaces the CDI box, you don't have a problem there either.



A couple of caveats. One, your stator must be charging the battery, or you will soon drain the battery. And the bike will not run without a battery now. Start your bike and put a meter on the two battery posts. At 2000 RPM, you should be reading about 14.5 VDC.



Two, if the pulsar coils around the flywheel are bad, the Igntech will not be able to receive the pulse signal to time the spark. I think there are post for tests on how to determine the health of these.
 

·
Registered
Joined
·
9 Posts
ok gonna bump this thread!! need some help
. so i have ran all the test and it seems to be my high speed source coil is the problem. Only thing i need help with is maby u guys might know where i could get a set of just the source coil. Every thing ohmed out right just want to be a cheap a**. And i did read about the cdi replacement and that just seems to be the way to go..... any help where to buy this stuff would be great. thanks for you time and have a great day.
 

·
Registered
Joined
·
583 Posts
ok gonna bump this thread!! need some help
. so i have ran all the test and it seems to be my high speed source coil is the problem. Only thing i need help with is maby u guys might know where i could get a set of just the source coil. Every thing ohmed out right just want to be a cheap a**. And i did read about the cdi replacement and that just seems to be the way to go..... any help where to buy this stuff would be great. thanks for you time and have a great day.
The occasionally pop up on ebay, but either ignitech or a stator replacement is the way to go.
 

·
Registered
Joined
·
8,423 Posts

·
Super Moderator
Joined
·
23,231 Posts
I'm pretty sure Ray doesn't currently have any but another Oz member has a surplus, unused one if it's still available.



My bike has been running one of these for a year or so and it's very good. Sort of like the power supply side of an ignitec without the CDI side.



Ray knows about this and is a member here. PM Rayman. if you want to go this way, I think the feller was looking for $90.



Or... there's always the ignitec.
 

·
Registered
Joined
·
8,423 Posts
I'm pretty sure Ray doesn't currently have any but another Oz member has a surplus, unused one if it's still available.



My bike has been running one of these for a year or so and it's very good. Sort of like the power supply side of an ignitec without the CDI side.



Ray knows about this and is a member here. PM Rayman. if you want to go this way, I think the feller was looking for $90.



Or... there's always the ignitec.


Even $90 seems a little excessive.I've chatted with Rayman a couple of times on the subject and thought the kits were a lot cheaper that he had?
 

·
Super Moderator
Joined
·
23,231 Posts
As a kit perhaps. I paid the going rate of $150 for mine.



I have an ignitec from the last group buy but I've had the luxury of being allowed to not get around to fitting it.



One of the other hulks here will no doubt require it.
 

·
Registered
Joined
·
8,423 Posts
As a kit perhaps. I paid the going rate of $150 for mine.



I have an ignitec from the last group buy but I've had the luxury of being allowed to not get around to it.



One of the other hulks here will no doubt require it.


I'm in the fortunate position of having two spare working CDI units and a 3rd I can call on anytime plus a spare CX500 and enough bits to make another<Smug mode off:>
 

·
Registered
Joined
·
9 Posts
well droped my motor tonight got it off new stator in and got every thing hooked back up ready for all fluids....... But wait i didn't check to see if it would switch gears and guess what it doesn't gotta pull every thing back out and try and see where i messed up the gear shift. It just seams to be locked up and will not do any thing. I have an 81cx500 custom. if any one has done the same thing some help would be great. I pulled the peace apart when pulling the back plate off and put it to together with the gears meshing and the spring back on but no luck with shifting. gonna go get some sleep and quess i will drop the motor again tomorrow...... What a pain in the a$$!!!!!!!!!!
 
1 - 20 of 22 Posts
Top