Honda CX 500 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
724 Posts
Discussion Starter · #1 ·
for months now i've had a leak from the thermostat housing. i thought it was the pipes on the side because i was seeing the coolant pool out of there so i would replace the o ring and it never stopped. last night i pulled the top of the t stat housing off. i figured the o- ring on top had rotted out but when i got it off and felt under there, no o-ring what so ever. oops. so needless to say i put an o ring in there and i'm pretty confident i've taken care of the leak
 

·
Registered
Joined
·
724 Posts
Discussion Starter · #3 ·
i think the leak was so big that it was collecting and exiting from around the pipe. thats why i thought the o ring on the pipe was leaking. i'll add fluid tonight and make sure it doesnt leak.
 

·
Registered
Joined
·
1,556 Posts
i think the leak was so big that it was collecting and exiting from around the pipe. thats why i thought the o ring on the pipe was leaking. i'll add fluid tonight and make sure it doesnt leak.


Sounds like some of the things I have done before. No reason to feel silly.



I think one of my favorites when I worked on cars (for very little more than fun) was a guy who had filled his thermostat with RTV thinking you needed A LOT to get a good seal. So being the moron I am I showed it to him and told him whoever had done this did not know what they were doing and he should not allow them to work on his car again. He then admitted he had done it. I felt stupid about that time.



 
1 - 5 of 5 Posts
Top