Honda CX 500 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Guys…can you help me diagnose what’s wrong with my bike?…it was fine until I took the battery out and recharged it. Now when I put the battery back and connect +ve and -ve cable, it starts cranking…the key is not in the bike so ignition is off also the kill switch is in off position…regardless the bike starts cranking as soon as I connect both wires to the battery and it won’t stop until I unplug it. I have no idea what’s wrong and how to figure it out! I remember that it started cranking when I was trying to take the battery out with some spark on the negative terminal but I didn’t think twice about and quickly took the battery off it then. Please give me some guidance on how to diagnose it and fix the issue!
 

·
Super Moderator
Joined
·
23,833 Posts
My guess is this.

You were attempting to start the bike with an undercharged battery and this has caused the starter solenoid contacts to fuse. It's happened to me.

Tapping the solenoid may free it up with luck.

They can be dismantled and cleaned but there is a risk to this due to the small internal wires which can be easily broken.

Or they are a cheap replacement.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
You are right, I was trying to start the bike on a weak battery. Thank you very much! I’ll replace the part like you’ve mentioned and let you know. :D
 

·
Registered
1982 GL500i
Joined
·
516 Posts
Supernatural possession. Happens to my bikes all the time. I have to keep them chained down, or they will go without me, lol!
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
!Problem solved! Thank you very much everyone for helping me. It was the starter solenoid, costs around 7-8$ on amazon and solved the problem.
This is an amazing group of people here, I really appreciate your help.😃
 
1 - 5 of 5 Posts
Top