Honda CX 500 Forum banner

Does Ignitech bypass stator on a CDI bike?

7959 Views 9 Replies 6 Participants Last post by  BernieR
Greetings folks:



I am new to the group, although I have frequently visited as a guest to get tech info. I have read a lot about the Ignitech as a possible cure-all for CDI/Stator issues, but I don't fully understand how it works or where it fits into the overall electrical system once installed; i.e. does it transform the bike from a CDI to a TI ignition, and therefore by-pass the CDI or the stator?



Here is my problem: I have a 1981 CX500C that was running perfectly this past summer until it just died at a traffic light on my way home from work. It just flat cut-out and stopped running. The bike turns over but won't start. The carbs are fine beacuase I had them rebuilt when I bought the bike in order to get it running, and I put over a thousand miles on it before it quit running.



So far I have tried the following fixes: I bought an aftermarket CDI from RegulatorRectifier.com and plugged it in - no change. I then bought a used CDI Pulser on-line, (not sure if the term is correct but it's the part that goes in the back engine cover) that supposedly came off a running bike, and I had a vintage bike mechanic install it - still no change. The mechanic thinks it is the main stator that is the problem since the bike isn't getting spark.



The person I bought the bike from had already cracked open the engine and replaced the stator just prior to my purchasing it, but I don't know if it was aftermarket, used, or re-wound. I am trying to avoid having to take the engine apart again to replace the stator if at all possible. That's why I'm asking if the Ignitech can fix the problem and avoid this.



Any advice is greatly appreciated.



Matt S. - Frederick Maryland.
See less See more
1 - 1 of 10 Posts
OP needs to track down the fault before spending money on maybe the wrong thing.Other causes of none spark/none starting can be faulty ignition switch/dirty electrical block connectors/faulty starter button,faulty kill switch.These must be investigated 1st.


On this track, you're sure you're getting fuel? It's not the vacuum fuel petcock? I say this because mine seems to be going south--sometimes seems to work, sometimes not.
1 - 1 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top