Honda CX 500 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've had my '82 GL 500 for a few years and have done quite a bit of work on it, but not much electrical. I've been riding quite a bit lately, and just noticed yesterday that my brake lights are staying on all the time. The brakes seem to be working fine, although I do need to deal with a bit of a dragging front brake. That wouldn't affect the brake light, wold it? Is there a switch stuck somewhere? Any ideas on where to start? I appreciate any help you can give.Thanks!
 

·
Super Moderator
Joined
·
15,414 Posts
Your brake lights should be on all the time as running lights. Are you sure you aren't seeing the runners and not the actual brighter brake light.



If it is a switch stuck I would say it would have to be the rear one behind the left foot peg.



Do a quick test and turn the bike on and press the peddle or pull in the brake lever and see if it lights up more.
 

·
Registered
Joined
·
801 Posts
Check it like BlindStitch suggest...except look behind the right foot peg





it does need adjustment from time to time, just turn the lock nut. lets hope that it.
 

·
Super Moderator
Joined
·
15,414 Posts
Odd. I wonder why honda put the cx on the left and the gl on the right. By now they probably have it built in to the monoshock just to screw with people.
 

·
Registered
Joined
·
967 Posts
Odd. I wonder why honda put the cx on the left and the gl on the right.


On my 79CX500C, it is on the Left rear, but seems to be closer and more exposed to road spray & the elements...maybe it is on the right, up higher, and tucked in more to keep it drier/cleaner?
 
1 - 5 of 5 Posts
Top