Honda CX 500 Forum banner

turn signals

  1. Custom How To
    Hello, I have a 82 Honda GL500 Interstate SilverWing I picked up a few weeks ago, I'm a junior tech at the Honda Powersports shop I work at so I come across a lot of cheap upgrade (which is how I wound up with these) but I'm stuck on an issue. I am in the middle of converting the front end from...
  2. Technical Help Forum
    Hello all, I'm new to the forum but have been consulting it since I got my first CX about 3 months ago. I am just buttoning up my cafe build and have installed LED strip turn signals in the front and rear. I have bought an LED compatible relay that should be allowing my turn signals to blink...
  3. Selling and Buying Forum
    Selling the original turn signals from my bike as I am not going to use them. They worked fine before I took them off. Asking $35+shipping for all OBO Thank you
  4. Technical Help Forum
    I just bought a 1982 GL500, everything worked perfectly... I removed the toolbox and the left rear turn signal came loose. I rewired the turn signal and now none of the turn signals work and the headlight does not turn on. The brake/tail light still work. I replaced all fuses, checked for loose...
  5. Technical Help Forum
    Sorry if this topic is posted somewhere else already, but I tried for an hour and couldn't find it. I've got a 1982 gl500 that's pretty much stock with some new incandescent turn signals installed. The original two prong flasher relay went bad so I replaced it with a new one that also had two...
  6. Technical Help Forum
    Wired everything up correctly tested it worked fine Next day left signal works but right side not working just a fast clicking in the signal relay Switched out the relay ...not the relay Tried to re do wiring popped some fuses Need your help!
Top