Honda CX 500 Forum banner

Discussions Showcase Albums Media Media Comments Tags

1-5 of 5 Results
  1. Technical Help Forum
    Hey everyone! I recently "completed" my first rebuild and It was running fantastic! ... for about 4 days, until I bottomed out my suspension because I forgot to double check the PSI in the rear air shock. Long story short, it completely obliterated my new tail light as well as all of the wiring...
  2. Technical Help Forum
    Hello all, i poseted a few days ago after I stated my cx for the first time in 10 years, I have solved everything else beside the misfiring/inconsistent out of the left cylinder. I have email Raymond, and he has been a great help so far, but I thought I would get a few others to give me some...
  3. Technical Help Forum
    Hi forum! I'm made it back after a year and 42,000 km on my CX500 around North and Central america. Had to rebuild the engine a couple times, so I'm getting better at taking care of my CX. In the last rebuilt I used half of another engine to fix the problems i had, but the camshaft's rear...
  4. Australia - CX500
    WANTED: CX500 (80) deluxe / standard tank with no bog (body filler) Hey im looking for a 80 deluxe tank in a good condition that has no bog (body filler) with either an OEM paint job or with a wire brush finish. Im located in Perth but im happy to pay for postage. Cheers
  5. Technical Help Forum
    I am working on a 79 CX500. I have completely restored one of these in the past and still own it. This one is for a customer. Low miles, 12k. Great compression. Previous owner had the stator fail, he replaced it and could not get it running. That's how I got it. I found he had the Green wire on...
1-5 of 5 Results
Top